home | area personale         schemi | tutorial | robotica | pic micro | recensioni         forum | chat irc         faq | contatti         store | Ordina PCB
username
password
cerca

 
FORUM: Elettronica Generale
Qui si parla di tutto....dall'analogico al digitale, dal software all'hardware, dal semplice crepuscolare al computer.


triac e relè 220vac
     
Autore Messaggio opzioni
gironico




una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli


postato il:
13.02.2018, alle ore 16:06
triac e relè 220vac 

Ciao a tutti, premetto che ho risolto il problema, ma vorrei essere certo se ho capito veramente il problema o se ho risolto casualmente.

Per necessità di un mio amico che ha un\'officina di riparazione macchine agricole con impianto trifase >15 kw ho installato un dispositivo di controllo con esp/telegram su un relè per comandare un vecchio teleruttore che a sua volta comanda un bruciatore a gasolio.

Il circuito di controllo è esattamente pari a quello del primo articolo che ho scritto recentemente su Telegram ed ESP.... optoisolatore moc 3021 e il bta06 e lo snubber annesso.

Testato su lampada in laboratorio ad incandescenza 60W e su una plafo con reattore elettromeccanico(non ho controllato se vi è il condensatore a bordo per rifasamento per il reattore...spero di si).
Il circuito rispondeva bene agli on/off

Monto il circuito in officina e il relè si eccita quando dico io ma non ne vuole sapere di diseccitarsi.

Rimediando una lampadina alogena da circa 20-28W(non ricordo bene), se la collego in parallelo sulla bobina del relè, il relè si spegne.

Ricapitolando: Invio messaggio accendi e relè si accende, invio comando spegni e il relè rimane dove è. Se vado ad applicare la lampadina sopracitata dopo l\'invio del comando spegni, il relè si diseccita e il circuito funziona benissimo solo se tengo la lampadina in parallelo al relè.

Provato con una lampadina a bassissimo consumo tipo quelle da segnalazione da pannello e si ripresenta il medesimo problema.

Inizio a fare delle considerazioni:

1)Il relè è un carico induttivo, quindi potrebbe creare uno sfasamento e quindi un ritardo della corrente rispetto alla tensione e con il moc3021 rilevo solo il passaggio della tensione per lo 0 quindi il triac mi rimane agganciato

Provo con 100nf in parallelo alla bobina del relè e non risolvo.
Provo con un 470 nF e il circuito funziona benissimo.

Mi sembra impossibile che mettano in commercio relè che creano uno sfasamento del genere, trall\'altro appena acquistato e provato con un altro nuovo per scongiurare un difetto.

Quindi mi viene da pensare, e qui la domanda:

L\'impianto potrebbe essere sfasato per altri motivi che possono essere molteplici senza starvi ad elencarli e quindi il relè si trova alimentato da una fase già sfasata in partenza ed è per questo che non spengo il triac?

Oppure l\'estra tensione generata al momento del diseccitamento della bobina è sufficiente a far rimanere il triac in conduzione? Se cosi avrei risolto solo con una capacità? Mi pare strano



Piano bimbo fai piano. La Vigna è grande e il trattore è sempre quello che è!
caccamo2





postato il:
13.02.2018, alle ore 17:15
-parli di moc generici senza citare il costruttore, a parita' di partnumber possono cambiare molte specifiche

-dici che il circuito e' lo stesso ma qua parli di 3021, nell'articolo hai usato 3061, uno e' zero cross, l'altro random phase, solo quest'ultimo va utilizzato con carichi induttivi.

-3061 pare obsoleto, invece 3021 e' qualificato per commutare carichi a 115VAC, non 230V.

-lo schema applicativo e' diverso e diversi sono i valori dei passivi esterni consigliati dal datasheet (a questo punto, chissa' di quale datasheet).

-il turn off fail e' causato dal dv/dt

chiarisci i suddetti punti e ridimensiona lo snubber, una capacita' in parallelo al carico non e' una buona soluzione.




VCC/2 IS A REFERENCE, NOT A VIRTUAL GROUND
gironico




una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli


postato il:
13.02.2018, alle ore 17:58
moc3061.... errore mio ...
obsoleto????
https://it.rs-online.com/web/p/accoppiatori-ottici/6711440/





Piano bimbo fai piano. La Vigna è grande e il trattore è sempre quello che è!
gironico




una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli


postato il:
13.02.2018, alle ore 18:03
il moc 3061 stando al data è in grado di lavorare su tensioni max di 240vac e dall'esempio lo snubber rc è come ho inserito io nel pcb 100nF---39ohm


Piano bimbo fai piano. La Vigna è grande e il trattore è sempre quello che è!
caccamo2





postato il:
13.02.2018, alle ore 18:08
di nuovo errore tuo, quello che hai linkato è il MOC3021M, che è diverso dal 3021 senza M, il quale è obsoleto e non indicato per carichi a 230VAC.

https://www.mouser.it/ProductDetail/Fairchild-Semiconductor/…

ad ogni modo, come ti dicevo, per carichi induttivi non vanno usati gli zero cross ma i random, lo schema giusto quindi è diverso dal tuo.



VCC/2 IS A REFERENCE, NOT A VIRTUAL GROUND
caccamo2





postato il:
13.02.2018, alle ore 18:10
*3061


VCC/2 IS A REFERENCE, NOT A VIRTUAL GROUND
gironico




una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli


postato il:
13.02.2018, alle ore 18:18
ad ogni modo, come ti dicevo, per carichi induttivi non vanno usati gli zero cross ma i random, lo schema giusto quindi è diverso dal tuo.


pardon, hai ragione, ho utilizzato quello che ho linkato.

e se è come dici, allora come mai mi funziona in applicazioni con reattori elettromeccanici per tubi a neon?

Cerco di capire dato che con questi componenti non ho molta esperienza. Grazie per le risposte



Piano bimbo fai piano. La Vigna è grande e il trattore è sempre quello che è!
zio bapu




una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli una ogni 10 livelli


postato il:
13.02.2018, alle ore 18:35
gironico:
ad ogni modo, come ti dicevo, per carichi induttivi non vanno usati gli zero cross ma i random, lo schema giusto quindi è diverso dal tuo.


pardon, hai ragione, ho utilizzato quello che ho linkato.

e se è come dici, allora come mai mi funziona in applicazioni con reattori elettromeccanici per tubi a neon?

Cerco di capire dato che con questi componenti non ho molta esperienza. Grazie per le risposte


Con i carichi induttivi vanno bene anche i zero cross, anzi, su alcune marche di caldaie per comandare la ventola di circa 50W usano un moc 3062 che comanda direttamente il gate tramite una 100 Ohm 1/4W, il triac e' un Z0410MF.

La bobina e' un induttore quasi puro e quindi sfasa molto corrente e tensione, quando la corrente scende a zero e il triac si spegne ai suoi capi appare la tensione di rete e se il valore e' alto il triac si autoinnesca.

Per curiosita' o per risolvere in futuro, potresti provare il circuito che ho indicato e con quel tipo di triac, in una riparazione ho messo un normale T0610MH e ha funzionato.



mandi
caccamo2





postato il:
13.02.2018, alle ore 18:50
ripeto, i triac in generale NON andrebbero utilizzati per carichi induttivi, ma se proprio, allora vanno usati assieme a fototriac random phase, in caso in cui si voglia utilizzare uno zero cross il circuito deve essere ancora diverso e piu complicato.
Questa cosa viene detta in tutte le application note dei costruttori, e si evince anche dai datasheet, che riportano lo schema applicativo di carichi solo resistivi nel caso di zero cross, anche induttivi nei random phase.
se voglio usare qualcosa fa riferimento quello che dice il costruttore, non quello che gli altri fanno.



VCC/2 IS A REFERENCE, NOT A VIRTUAL GROUND
caccamo2





postato il:
13.02.2018, alle ore 18:58
gironico:
e se è come dici, allora come mai mi funziona in applicazioni con reattori elettromeccanici per tubi a neon?

perché ti è andata di culo?
sai quante cose si costruiscono e funzionano anche se apparentemente non dovrebbero andare?
io ti ho detto quello che è l'arte nota e non è in discussione, se a te vanno significa che per qualche ragione o il carico è meno induttivo di quanto pensi o hai casualmente messo il fototriac in condizioni normali.



VCC/2 IS A REFERENCE, NOT A VIRTUAL GROUND
segui questo thread con grixFC, per questa funzione devi aver installato il software grixFC

torna su
     

Come utente anonimo puoi leggere il contenuto di questo forum ma per aprire una discussione
o per partecipare ad una discussione esistente devi essere registrato ed accedere al sito




 

 
 
indietro | homepage | torna su copyright © 2004/2018 GRIX.IT - La community dell'elettronica Amatoriale